Walka z excel ;)

Awatar użytkownika
wipstudio
Administrator Techniczny
Posty: 3791
Data: 17 paź 2009, 23:10
Skąd: Dąbrowa Górnicza

Walka z excel ;)

Postautor: wipstudio » 25 lis 2018, 14:21

Na podstawie LibreOffice ;)
Otóż musiałem zrobić wzór umowy z wypełnianiem podstawowych danych z bazy danych. Bazę tworzę ręcznie oczywiście.
Podstawianie danych po jakimś konkretnym parametrze zajęło mi dobre 3 godziny ale 4 stronicowa umowa została ogarnięta dzięki dość prostej funkcji wyszukaj pionowo.

Otóż wiele osób nie rozumie sposobu działania.
Pierwszy parametr określa w jakiej komórce jest szukana dana np 200
W arkuszu w jakim szukamy ten parametr winien być w pierwszej kolumnie gdyż tylko tam ta funkcja szuka tego parametru.
Ok. Mamy już Szukaną np komórkę K3, drugim parametrem określamy zakres gdzie szukamy np A2:G9999, w tych komórkach będzie szukany parametr z komórki K3. Skoro wiemy co i gdzie pora określic co szukamy.
Indeksem określimy kolejną kolumnę jaka nas interesuje np.

ID | Name | TEL | MAIL
200|AAB | None|fckgw@qq2.pl
liczymy kolejno kolumny i jeśli chcemy uzyskać kolumnę MAIL to wpisujemy liczbę 4
W przypadku błędów należy ustalić metodę sortowania więc najlepiej wpisać 0 lub FAŁSZ()

Kod: Zaznacz cały

=WYSZUKAJ.PIONOWO(G1;A1:D4;4;FAŁSZ())

Poniżej przykładowy plik ;)

http://uploadfile.pl/pokaz/1562891---3gsr.html

Wróć do „Software”



Kto jest online

Użytkownicy przeglądający to forum: Obecnie na forum nie ma żadnego zarejestrowanego użytkownika i 1 gość